Puzzle ITC - files.puzzle.ch unavailable – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
All systems operational
files.puzzle.ch unavailable
Resolved
Operational
Started 8 months ago
Lasted 19 minutes
Affected
Puzzle Services
Operational from 9:33 AM to 9:52 AM
Nextcloud
Operational from 9:33 AM to 9:52 AM
Updates
Resolved
7. March 2024 at 9:52
Resolved
7. March 2024 at 9:52
This incident has been resolved.
Investigating
7. March 2024 at 9:33
Investigating
7. March 2024 at 9:33
We are currently investigating this incident.