Scheduled for 27. June 2024 at 15:0 – 16:0
Affects
Puzzle Services
Under maintenance from 3:00 PM to 4:00 PM
Mail
Under maintenance from 3:00 PM to 4:00 PM
Completed
27. June 2024 at 16:0Completed
27. June 2024 at 16:0Maintenance has completed successfully
In progress
27. June 2024 at 15:0In progress
27. June 2024 at 15:0Maintenance is now in progress
Planned
27. June 2024 at 15:0Planned
27. June 2024 at 15:0We will be migrating our inbound mail infrastructure (mx servers) today, starting at 5pm. During this time, there might be slight delays of a couple of minutes for inbound messages. Thank you for your understanding.